Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
8.6

CVE-2026-42089: Yeoman Environment Vulnerable to Malicious Package Installation

CVE-2026-42089 · published 4 months ago
Summary

Versions of Yeoman Environment (2.9.0 to 6.0.1) can install packages without user approval, potentially allowing attackers to execute code. To fix this, update to version 6.0.1, which adds a confirmation prompt. No temporary workarounds are available, so an update is necessary.

What to do
  • Update GitHub Actions yeoman-environment to version 6.0.1.
Affected software
Ecosystem VendorProductAffected versions
npm GitHub Actions yeoman-environment >= 2.9.0, < 6.0.1
Fix: upgrade to 6.0.1
Original advisory text
yeoman-environment Vulnerable to Arbitrary Package Installation without User Confirmation
Yeoman Environment provides an API to discover, create, and run generators, and to configure where and how a generator is resolved. Versions 2.9.0 through 6.0.0 install missing local generator packages from caller-supplied package names without user confirmation. In downstream consumers that pass attacker-controlled project configuration into this path, this can result in arbitrary package installation and code execution during CLI bootstrap. The vulnerable method is installLocalGenerators(), which calls repository.install() directly without prompting the user. This issue has been fixed in version 6.0.0.
Fix within
Internet-facing 14 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit
  • Gives an attacker full control
Severity
8.6 High
Exploitation
<1% chance of attack within 30 days
Type
CWE-829Inclusion of Functionality from Untrusted Control Sphere
Timeline
Published16 Jun 2026
Updated27 Oct 2026
First seen26 May 2026
Sources
Track software like this
Free during beta