Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
6.6

CVE-2026-35197: dye library can run unwanted code via templates

CVE-2026-35197 · published 7 months ago
Summary

The dye color library for shell scripts (versions before 1.1.1) lets specially crafted template expressions cause the system to run any command the attacker wants. This could let an attacker take control of the script’s environment. Update dye to version 1.1.1 or later to stop the issue.

What to do

The CVE record does not list a fixed version. Check the vendor's site or the advisory links below - a fix may already be released.

Affected software
VendorProductAffected versions
mattiebee dye 1.1.0
cpe:2.3:a:mattiebee:dye:1.1.0:*:*:*:*:*:*:*
Original advisory text
Code injection in dye template expressions
dye is a portable and respectful color library for shell scripts. Prior to 1.1.1, certain dye template expressions would result in execution of arbitrary code. This issue was discovered and fixed by dye's author, and is not known to be exploited. This vulnerability is fixed in 1.1.1.
Fix within
Internet-facing 14 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit
  • Gives an attacker full control
Severity
6.6 Medium
Exploitation
<1% chance of attack within 30 days
Type
CWE-94Code Injection
Timeline
Published6 Apr 2026
Updated3 Nov 2026
First seen6 Apr 2026
Sources
Track software like this
Free during beta