Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
5.9
CVE-2026-34956: Debian Linux: Unauthenticated Remote Code Execution in Samba Service
CVE-2026-34956 · published 6 months ago
Summary
A security issue affects the Samba service on Debian Linux, potentially allowing attackers to execute malicious code on affected systems without needing a password. This could lead to unauthorized access and data theft. Update your Samba service to the latest version to mitigate this risk.
What to do
- Update debian openvswitch to version 3.7.1-1.
Affected software
| Ecosystem | Vendor | Product | Affected versions |
|---|---|---|---|
| Debian:11 | debian | openvswitch | All versions |
| Debian:12 | debian | openvswitch | All versions |
| Debian:13 | debian | openvswitch | All versions |
| Debian:14 | debian | openvswitch |
< 3.7.1-1 Fix: upgrade to 3.7.1-1
|
| – | red hat | fast datapath for rhel 7 | All versions |
| – | red hat | fast datapath for rhel 8 | All versions |
| – | red hat | fast datapath for rhel 9 | All versions |
| – | red hat | red hat enterprise linux 7 | All versions |
| – | red hat | red hat openshift container platform 4 | All versions |
| – | red hat | red hat openstack platform 13 (queens) | All versions |
| – | red hat | red hat openstack platform 16.2 | All versions |
| – | red hat | red hat openstack platform 17.1 | All versions |
| – | red hat | red hat openstack platform 18.0 | All versions |
| Ubuntu:Pro:18.04:LTS | canonical | openvswitch | All versions |
| Ubuntu:20.04:LTS | canonical | openvswitch | All versions |
| Ubuntu:22.04:LTS | canonical | openvswitch | All versions |
| Ubuntu:24.04:LTS | canonical | openvswitch | All versions |
| Ubuntu:25.10 | canonical | openvswitch | All versions |
| Ubuntu:26.04:LTS | canonical | openvswitch | All versions |
Original advisory text
A flaw was found in Open vSwitch. When Open vSwitch is configured with a conntrack flow using FTP helpers over the userspace datapath, a remote attacker can send a specially crafted FTP stream with...
A flaw was found in Open vSwitch. When Open vSwitch is configured with a conntrack flow using FTP helpers over the userspace datapath, a remote attacker can send a specially crafted FTP stream with an EPASV command exceeding 255 characters. This heap access error can lead to a crash, resulting in a Denial of Service (DoS) for the affected system.
References
- https://security-tracker.debian.org/tracker/CVE-2026-34956 Vendor Advisory
- https://mail.openvswitch.org/pipermail/ovs-dev/2026-March/431425.html Third Party Advisory
- https://www.openwall.com/lists/oss-security/2026/03/31/15 Third Party Advisory
- https://www.cve.org/CVERecord?id=CVE-2026-34956 Third Party Advisory
- https://ubuntu.com/security/CVE-2026-34956 Third Party Advisory
- https://access.redhat.com/security/cve/CVE-2026-34956
- https://bugzilla.redhat.com/show_bug.cgi?id=2453459
- http://www.openwall.com/lists/oss-security/2026/03/31/15
Internet-facing
60 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit
- Gives an attacker partial control
Type
CWE-120Classic Buffer Overflow
Timeline
Published5 May 2026
Updated4 Nov 2026
First seen1 Apr 2026
Sources
CVE-2026-34956 · MITRE
CVE-2026-34956 · NVD
DEBIAN-CVE-2026-34956 · OSV
UBUNTU-CVE-2026-34956 · OSV
Track software like this
Free during beta