Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
6.8
CVE-2026-34080: xdg-dbus-proxy can let unauthorized apps read messages
CVE-2026-34080 · published 7 months ago
Summary
The xdg-dbus-proxy program that filters D-Bus communications on Debian, Flatpak, and Canonical systems can be tricked into allowing apps to see messages they shouldn't. This happens because the filter doesn't recognize a small formatting difference in its rules. Upgrade to version 0.1.7 or later to close the gap.
What to do
- Update canonical xdg-dbus-proxy to version 0.1.3-1ubuntu0.1.
- Update canonical xdg-dbus-proxy to version 0.1.5-1ubuntu0.2.
- Update canonical xdg-dbus-proxy to version 0.1.6-1ubuntu0.1.
- Update flatpak xdg-dbus-proxy to version 0.1.7 or later.
Affected software
| Ecosystem | Vendor | Product | Affected versions |
|---|---|---|---|
| Debian:11 | debian | xdg-dbus-proxy | All versions |
| Debian:12 | debian | xdg-dbus-proxy | All versions |
| Debian:13 | debian | xdg-dbus-proxy | All versions |
| Debian:14 | debian | xdg-dbus-proxy | All versions |
| – | flatpak | xdg-dbus-proxy |
< 0.1.7 cpe:2.3:a:flatpak:xdg-dbus-proxy:*:*:*:*:*:*:*:* |
| Ubuntu:Pro:20.04:LTS | canonical | xdg-dbus-proxy | All versions |
| Ubuntu:22.04:LTS | canonical | xdg-dbus-proxy |
< 0.1.3-1ubuntu0.1 Fix: upgrade to 0.1.3-1ubuntu0.1
|
| Ubuntu:24.04:LTS | canonical | xdg-dbus-proxy |
< 0.1.5-1ubuntu0.2 Fix: upgrade to 0.1.5-1ubuntu0.2
|
| Ubuntu:25.10 | canonical | xdg-dbus-proxy |
< 0.1.6-1ubuntu0.1 Fix: upgrade to 0.1.6-1ubuntu0.1
|
Original advisory text
xdg-dbus-proxy has an eavesdrop filter bypass allowing message interception
xdg-dbus-proxy is a filtering proxy for D-Bus connections. Prior to 0.1.7, a policy parser vulnerability allows bypassing eavesdrop restrictions. The proxy checks for eavesdrop=true in policy rules but fails to handle eavesdrop ='true' (with a space before the equals sign) and similar cases. Clients can intercept D-Bus messages they should not have access to. This vulnerability is fixed in 0.1.7.
References
- https://github.com/flatpak/xdg-dbus-proxy/security/advisories/GHSA-vjp5-hjfm-767... Vendor Advisory
- http://www.openwall.com/lists/oss-security/2026/04/10/15 URL
- https://www.cve.org/CVERecord?id=CVE-2026-34080 Third Party Advisory
- https://ubuntu.com/security/notices/USN-8167-1 Vendor Advisory
- https://ubuntu.com/security/CVE-2026-34080 Third Party Advisory
- https://security-tracker.debian.org/tracker/CVE-2026-34080 Vendor Advisory
- https://lists.debian.org/debian-lts-announce/2026/04/msg00022.html URL
- https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/34xxx/CVE-2026-34080... Vendor Advisory
- https://nvd.nist.gov/vuln/detail/CVE-2026-34080 Vendor Advisory
Internet-facing
60 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit
- Gives an attacker partial control
Type
CWE-1289Improper Validation of Unsafe Equivalence in Input
Timeline
Published7 Apr 2026
Updated4 Nov 2026
First seen7 Apr 2026
Sources
CVE-2026-34080 · NVD
DEBIAN-CVE-2026-34080 · OSV
UBUNTU-CVE-2026-34080 · OSV
CVE-2026-34080 · OSV
GHSA-vjp5-hjfm-7677 · GHSA
Track software like this
Free during beta