Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
6.3

CVE-2026-3283: libvips can read beyond memory and crash

CVE-2026-3283 · published 8 months ago
Summary

The libvips image library (versions including 8.19.0) has a bug in its extract function that can cause it to read data outside its allocated space. This could lead to unexpected behavior or crashes when the library processes specially crafted input on the same machine. Updating libvips with the provided patch or a newer version resolves the issue.

What to do
  • Update debian vips to version 8.18.0-3.
Affected software
Ecosystem VendorProductAffected versions
– libvips libvips 8.19.0
cpe:2.3:a:libvips:libvips:8.19.0:*:*:*:*:*:*:*
Debian:11 debian vips All versions
Debian:12 debian vips All versions
Debian:13 debian vips All versions
Debian:14 debian vips < 8.18.0-3
Fix: upgrade to 8.18.0-3
Ubuntu:Pro:16.04:LTS canonical vips All versions
Original advisory text
libvips extract.c vips_extract_band_build out-of-bounds
A vulnerability has been found in libvips 8.19.0. This issue affects the function vips_extract_band_build of the file libvips/conversion/extract.c. The manipulation of the argument extract_band leads to out-of-bounds read. The attack needs to be performed locally. The exploit has been disclosed to the public and may be used. The identifier of the patch is 24795bb3d19d84f7b6f5ed86451ad556c8f2fe70. To fix this issue, it is recommended to deploy a patch.
Fix within
Internet-facing 60 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit
  • Gives an attacker partial control
Severity
6.3 Medium
Exploitation
<1% chance of attack within 30 days
Type
CWE-119Buffer Overflow
CWE-125Out-of-bounds Read
Timeline
Published27 Feb 2026
Updated4 Nov 2026
First seen6 Mar 2026
Track software like this
Free during beta