Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
6.0

CVE-2026-32023: Old OpenClaw versions allow malicious code to run without approval

CVE-2026-32023 · published 7 months ago
Summary

Old versions of OpenClaw can be tricked into running malicious code without asking for permission. This affects system.run commands in allowlist mode. Update to OpenClaw version 2026.2.24 or later to fix this issue.

What to do
  • Update GitHub Actions openclaw to version 2026.2.24.
  • Update openclaw openclaw to version 2026.2.24 or later.
Affected software
Ecosystem VendorProductAffected versions
– openclaw openclaw < 2026.2.24
cpe:2.3:a:openclaw:openclaw:*:*:*:*:*:node.js:*:*
npm GitHub Actions openclaw < 2026.2.24
Fix: upgrade to 2026.2.24
Original advisory text
OpenClaw's dispatch-wrapper depth-cap mismatch can bypass shell-wrapper approval gating in system.run allowlist mode
OpenClaw versions prior to 2026.2.24 contain an approval gating bypass vulnerability in system.run allowlist mode where nested transparent dispatch wrappers can suppress shell-wrapper detection. Attackers can exploit this by chaining multiple dispatch wrappers like /usr/bin/env to execute /bin/sh -c commands without triggering the expected approval prompt in allowlist plus ask=on-miss configurations.
Fix within
Internet-facing 60 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit
  • Gives an attacker partial control
Severity
6.0 Medium
Exploitation
<1% chance of attack within 30 days
Type
CWE-863Incorrect Authorization
CWE-284Improper Access Control
Timeline
Published19 Mar 2026
Updated3 Nov 2026
First seen19 Mar 2026
Sources
Track software like this
Free during beta