Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
7.8

CVE-2026-3084: GStreamer H.266 parser can let attackers run code

CVE-2026-3084 · published 7 months ago
Summary

The GStreamer multimedia library’s H.266 codec component may accept specially crafted video data that causes a calculation error, allowing a remote attacker to run their own code on the system. This affects installations that include the GStreamer core or the bad plugins packages from Debian or Canonical. Update to the latest patched versions or disable the H.266 parser until a fix is applied.

What to do
  • Update debian gst-plugins-bad1.0 to version 1.28.1-1.
  • Update debian gst-plugins-bad1.0 to version 1.26.2-3+deb13u1.
  • Update gstreamer gstreamer to version 1.28.1 or later.
Affected software
Ecosystem VendorProductAffected versions
Debian:13 debian gst-plugins-bad1.0 < 1.26.2-3+deb13u1
Fix: upgrade to 1.26.2-3+deb13u1
Debian:14 debian gst-plugins-bad1.0 < 1.28.1-1
Fix: upgrade to 1.28.1-1
– gstreamer gstreamer < 1.28.1
1c6e163aa33962f5ee4a87d29319ccdd5cb67612
cpe:2.3:a:gstreamer:gstreamer:*:*:*:*:*:*:*:*
Ubuntu:Pro:14.04:LTS canonical gst-plugins-bad1.0 All versions
Original advisory text
GStreamer H.266 Codec Parser Integer Underflow Remote Code Execution Vulnerability
GStreamer H.266 Codec Parser Integer Underflow Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of GStreamer. Interaction with this library is required to exploit this vulnerability but attack vectors may vary depending on the implementation.

The specific flaw exists within the parsing of picture partitions. The issue results from the lack of proper validation of user-supplied data, which can result in an integer underflow before writing to memory. An attacker can leverage this vulnerability to execute code in the context of the current process. Was ZDI-CAN-28910.
Fix within
Internet-facing 14 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit
  • Gives an attacker full control
Severity
7.8 High
Exploitation
<1% chance of attack within 30 days
Type
CWE-191Integer Underflow (Wrap or Wraparound)
Timeline
Published13 Mar 2026
Updated4 Nov 2026
First seen14 Mar 2026
Track software like this
Free during beta