Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
8.9

CVE-2026-28463: OpenClaw before 2026.2.14 can expose files via shell expansion

CVE-2026-28463 · published 8 months ago
Summary

Versions of OpenClaw released before 2026.2.14 allow specially crafted commands to read any file that the gateway or node can access. This happens because the program checks command arguments before they are expanded by the shell, but then runs the expanded version, letting attackers use patterns or environment variables to pull out data. Upgrade to version 2026.2.14 or later, or disable host command execution if you cannot upgrade.

What to do
  • Update steipete openclaw to version 2026.2.14.
  • Update openclaw openclaw to version 2026.2.14 or later.
Affected software
Ecosystem VendorProductAffected versions
npm steipete openclaw < 2026.2.14
Fix: upgrade to 2026.2.14
– openclaw openclaw < 2026.2.14
cpe:2.3:a:openclaw:openclaw:*:*:*:*:*:node.js:*:*
Original advisory text
OpenClaw < 2026.2.14 - Arbitrary File Read via Shell Expansion in Safe Bins Allowlist
OpenClaw versions prior to 2026.2.14 contain an arbitrary file read vulnerability in the exec-approvals allowlist validation that checks pre-expansion argv tokens but executes using real shell expansion. Attackers with authorization or through prompt-injection attacks can exploit safe binaries like head, tail, or grep with glob patterns or environment variables to disclose files readable by the gateway or node process when host execution is enabled in allowlist mode.
Fix within
Internet-facing 14 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit
  • Gives an attacker full control
Severity
8.9 High
Exploitation
<1% chance of attack within 30 days
Type
CWE-78OS Command Injection
Timeline
Published5 Mar 2026
Updated31 Oct 2026
First seen6 Mar 2026
Sources
Track software like this
Free during beta