Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
6.5

CVE-2026-27058: Penci Podcast allows hackers to inject malicious code into web pages

CVE-2026-27058 · published 8 months ago
Summary

A security weakness in Penci Podcast allows hackers to inject malicious code into web pages visited by users. This could potentially allow an attacker to steal sensitive information or take control of a user's account. Update to version 1.8 or later to fix the issue.

Original advisory text
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in PenciDesign Penci Podcast penci-podcast allows DOM-Based XSS.This issue affects Penci Podcast: ...
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in PenciDesign Penci Podcast penci-podcast allows DOM-Based XSS.This issue affects Penci Podcast: from n/a through <= 1.7.
Fix within
Internet-facing 60 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit
  • Gives an attacker partial control
Severity
6.5 Medium
Exploitation
<1% chance of attack within 30 days
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published19 Feb 2026
Updated26 Oct 2026
First seen6 Mar 2026
Sources
Track software like this
Free during beta