Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
7.5

CVE-2026-25148: Qwik framework server rendering can run attacker scripts

CVE-2026-25148 · published 9 months ago
Summary

The Qwik web framework (including Qwik City) could insert malicious code into pages it builds on the server. An attacker could place harmful scripts that run in users' browsers when they view the page, potentially stealing data or hijacking sessions. Upgrade to Qwik version 1.19.0 or later to eliminate the risk.

What to do
  • Update builder.io qwik-city to version 1.19.0.
  • Update qwik qwik to version 1.19.0 or later.
Affected software
Ecosystem VendorProductAffected versions
npm builder.io qwik-city < 1.19.0
Fix: upgrade to 1.19.0
– qwik qwik < 1.19.0
cpe:2.3:a:qwik:qwik:*:*:*:*:*:node.js:*:*
Original advisory text
Qwik SSR XSS via Unsafe Virtual Node Serialization
Qwik is a performance focused javascript framework. Prior to version 1.19.0, a Cross-Site Scripting vulnerability in Qwik.js' server-side rendering virtual attribute serialization allows a remote attacker to inject arbitrary web scripts into server-rendered pages via virtual attributes. Successful exploitation permits script execution in a victim's browser in the context of the affected origin. This issue has been patched in version 1.19.0.
Fix within
Internet-facing 60 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit
  • Gives an attacker partial control
Severity
7.5 High
Exploitation
<1% chance of attack within 30 days
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published3 Feb 2026
Updated4 Nov 2026
First seen6 Mar 2026
Sources
Track software like this
Free during beta