Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
8.1

CVE-2026-14668: PostgreSQL may let attacker read small memory fragment

CVE-2026-14668 · published 2 months ago
Summary

Versions of PostgreSQL before the latest releases (16.15, 17.11, 18.6, 15.19, and 14.24) can be tricked into exposing a 4‑byte piece of the server's memory when a specially crafted query is run. This could let a malicious user discover internal data, which might aid further attacks. Update PostgreSQL to the mentioned newer versions or apply any vendor‑provided patches as soon as possible.

What to do
  • Update alpine postgresql16 to version 16.15-r0.
  • Update alpine postgresql17 to version 17.11-r0.
  • Update bellsoft postgresql17 to version 17.11-r0.
  • Update bellsoft postgresql18 to version 18.6-r0.
  • Update debian postgresql-15 to version 15.19-0+deb12u1.
  • Update debian postgresql-18 to version 18.6-1.
  • Update debian postgresql-13 to version 13.23-0+deb11u4.aikido.7.
  • Update debian postgresql-17 to version 17.11-0+deb13u1.
  • Update canonical postgresql-14 to version 14.24-0ubuntu0.22.04.1.
  • Update canonical postgresql-16 to version 16.15-0ubuntu0.24.04.1.
  • Update canonical postgresql-18 to version 18.6-0ubuntu0.26.04.1.
  • Update alpine postgresql18 to version 18.5-r0.
  • Update postgresql to version 18.5.0.
  • Update debian rootio-postgresql-13 to version 13.23-0+deb11u4.aikido.7.
Affected software
Ecosystem VendorProductAffected versions
Alpine:v3.22 alpine postgresql16 < 16.15-r0
Fix: upgrade to 16.15-r0
Alpine:v3.22 alpine postgresql17 < 17.11-r0
Fix: upgrade to 17.11-r0
Alpaquita:25 bellsoft postgresql17 >= 17.5-r0, < 17.11-r0
Fix: upgrade to 17.11-r0
Alpaquita:stream bellsoft postgresql18 >= 18.0-r0, < 18.6-r0
Fix: upgrade to 18.6-r0
Debian:12 debian postgresql-15 < 15.19-0+deb12u1
Fix: upgrade to 15.19-0+deb12u1
Debian:14 debian postgresql-18 < 18.6-1
Fix: upgrade to 18.6-1
Alpine:v3.24 alpine postgresql17 < 17.11-r0
Fix: upgrade to 17.11-r0
Root:Debian:11 debian postgresql-13 < 13.23-0+deb11u4.aikido.7
Fix: upgrade to 13.23-0+deb11u4.aikido.7
– – postgresql < 18.6
Debian:11 debian postgresql-13 All versions
Debian:13 debian postgresql-17 < 17.11-0+deb13u1
Fix: upgrade to 17.11-0+deb13u1
Ubuntu:Pro:14.04:LTS canonical postgresql-9.3 All versions
Ubuntu:Pro:16.04:LTS canonical postgresql-9.5 All versions
Ubuntu:Pro:18.04:LTS canonical postgresql-10 All versions
Ubuntu:20.04:LTS canonical postgresql-12 All versions
Ubuntu:22.04:LTS canonical postgresql-14 < 14.24-0ubuntu0.22.04.1
Fix: upgrade to 14.24-0ubuntu0.22.04.1
Ubuntu:24.04:LTS canonical postgresql-16 < 16.15-0ubuntu0.24.04.1
Fix: upgrade to 16.15-0ubuntu0.24.04.1
Ubuntu:26.04:LTS canonical postgresql-18 < 18.6-0ubuntu0.26.04.1
Fix: upgrade to 18.6-0ubuntu0.26.04.1
Alpine:v3.21 alpine postgresql16 < 16.15-r0
Fix: upgrade to 16.15-r0
Alpine:v3.21 alpine postgresql17 < 17.11-r0
Fix: upgrade to 17.11-r0
Alpine:v3.23 alpine postgresql17 < 17.11-r0
Fix: upgrade to 17.11-r0
Alpine:v3.23 alpine postgresql18 < 18.5-r0
Fix: upgrade to 18.5-r0
Alpine:v3.24 alpine postgresql18 < 18.5-r0
Fix: upgrade to 18.5-r0
– postgresql postgresql >= 14.0, < 14.24
>= 15.0, < 15.19
>= 16.0, < 16.15
>= 17.0, < 17.11
>= 18.0, < 18.5
cpe:2.3:a:postgresql:postgresql:*:*:*:*:*:*:*:*
Bitnami – postgresql >= 18.0.0, < 18.5.0
Fix: upgrade to 18.5.0
Root:Debian:11 debian rootio-postgresql-13 < 13.23-0+deb11u4.aikido.7
Fix: upgrade to 13.23-0+deb11u4.aikido.7
Original advisory text
Type confusion regarding input of PostgreSQL ctid data type selectivity estimator allows an object creator to view a calculation derived from the value of an arbitrary 4-byte span of memory, via a ...
Type confusion regarding input of PostgreSQL ctid data type selectivity estimator allows an object creator to view a calculation derived from the value of an arbitrary 4-byte span of memory, via a chosen non-ctid input. While the calculation loses precision, substantial memory value recovery appears possible. Versions before PostgreSQL 18.6, 17.11, 16.15, 15.19, and 14.24 are affected.
Fix within
Internet-facing 60 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit
  • Gives an attacker partial control
Severity
8.1 High
Exploitation
<1% chance of attack within 30 days
Type
CWE-843Type Confusion
Timeline
Published13 Aug 2026
Updated4 Nov 2026
First seen13 Aug 2026
Track software like this
Free during beta