Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
6.5

CVE-2026-115951: Lazy Load for Videos plugin lets attackers run code

CVE-2026-115951 · published 9 days ago
Summary

The Lazy Load for Videos plugin for WordPress (versions up to 2.18.11) can store hidden malicious scripts in video pages. When a visitor views the page, the script runs in their browser, potentially stealing data or altering the site appearance. Update the plugin to the latest version or remove it if you cannot apply the update.

What to do
  • Update kevin weber lazy load for videos to version 2.18.12.
Affected software
VendorProductAffected versions
kevin weber lazy load for videos <= 2.18.11
Fix: upgrade to 2.18.12
Original advisory text
WordPress Lazy Load for Videos plugin <= 2.18.11 - Cross Site Scripting (XSS) vulnerability
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Kevin Weber Lazy Load for Videos lazy-load-for-videos allows Stored XSS.This issue affects Lazy Load for Videos: from n/a through 2.18.11.
Fix within
Internet-facing 60 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit
  • Gives an attacker partial control
Severity
6.5 Medium
Exploitation
<1% chance of attack within 30 days
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published26 Oct 2026
Updated27 Oct 2026
First seen26 Oct 2026
Sources
CVE-2026-115951 · MITRE
Track software like this
Free during beta