Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
7.1
CVE-2026-114179: BP Better Messages plugin lets attackers inject malicious code
CVE-2026-114179 · published 11 days ago
Summary
The BP Better Messages add‑on for WordPress can run unsafe scripts supplied by a user, which could let an attacker display unwanted content or steal information from visitors. This affects versions up to 3.1.3. Update the plugin to the latest version or remove it until a safe update is available.
What to do
- Update wordplus bp better messages to version 3.1.4.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| wordplus | bp better messages |
<= 3.1.3 Fix: upgrade to 3.1.4
|
Original advisory text
WordPress BP Better Messages plugin <= 3.1.3 - Cross Site Scripting (XSS) vulnerability
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in wordplus BP Better Messages bp-better-messages allows DOM-Based XSS.This issue affects BP Better Messages: from n/a through 3.1.3.
Internet-facing
60 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit
- Gives an attacker partial control
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published24 Oct 2026
Updated29 Oct 2026
First seen24 Oct 2026
Track software like this
Free during beta