Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
8.8
CVE-2026-110196: Langflow OSS lets low‑privilege user run code on server
CVE-2026-110196 · published 6 days ago
Summary
Versions 1.0.0 through 1.12.4 of IBM Langflow OSS let a signed‑in user with limited rights bypass admin‑only checks and run their own code on the server. This could let an attacker take control of the system. Apply the latest updates and limit who can configure the code‑execution component.
What to do
- Update langflow langflow to version 1.12.5 or later.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| ibm | langflow oss | <= 1.12.4 |
| langflow | langflow |
>= 1.0.0, < 1.12.5 cpe:2.3:a:langflow:langflow:*:*:*:*:*:*:*:* |
Original advisory text
Langflow OSS is affected by multiple vulnerabilities
IBM Langflow OSS 1.0.0 through 1.12.4 could allow a remote attacker with a low-privileged authenticated account to bypass the administrator-only restriction and execute arbitrary code on the server by configuring a built-in code-execution component with attacker-supplied inputs.
References
- https://www.ibm.com/support/pages/node/7293016 Patch Vendor Advisory
Internet-facing
14 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit
- Gives an attacker full control
Type
CWE-862Missing Authorization
Timeline
Published29 Oct 2026
Updated4 Nov 2026
First seen29 Oct 2026
Track software like this
Free during beta