Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
9.8
CVE-2026-110186: IBM Langflow OSS may let remote attackers run code
CVE-2026-110186 · published 4 days ago
Summary
Versions 1.0.0 through 1.12.8 of IBM Langflow OSS can generate code in a way that an attacker on the network could cause the system to execute unwanted commands. This could lead to the attacker taking control of the server or accessing sensitive data. Upgrade to the latest released version or apply the vendor’s recommended patches to stop the risk.
What to do
- Update langflow langflow to version 1.13.0 or later.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| ibm | langflow oss | <= 1.12.8 |
| langflow | langflow |
>= 1.0.0, < 1.13.0 cpe:2.3:a:langflow:langflow:*:*:*:*:*:*:*:* |
Original advisory text
Langflow OSS is affected by multiple vulnerabilities
IBM Langflow OSS 1.0.0 through 1.12.8 could allow a remote attacker to execute arbitrary code due to improper control of code generation.
References
- https://www.ibm.com/support/pages/node/7294467 Patch Vendor Advisory
Internet-facing
3 days
Internal
60 days
- Not known to be exploited
- Can be exploited automatically
- Gives an attacker full control
Type
CWE-94Code Injection
Timeline
Published29 Oct 2026
Updated31 Oct 2026
First seen29 Oct 2026
Track software like this
Free during beta