Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
5.3
CVE-2026-107420: WordPress Pay With MetaMask plugin lets attackers skip payment
CVE-2026-107420 · published 25 days ago
Summary
The Pay With MetaMask for WooCommerce plugin (versions up to 1.7.2) allows anyone on the internet to bypass the normal checkout process and make purchases without proper verification. This could let malicious users obtain goods or services without paying. Update the plugin to a newer version or disable it until it is fixed.
What to do
- Update narinder singh pay with metamask for woocommerce – cryptocurrency payment gateway to version 1.7.3.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| narinder singh | pay with metamask for woocommerce – cryptocurrency payment gateway |
<= 1.7.2 Fix: upgrade to 1.7.3
|
Original advisory text
WordPress Pay With MetaMask For WooCommerce – Cryptocurrency Payment Gateway plugin <= 1.7.2 - Bypass Vulnerability vulnerability
Unauthenticated Bypass Vulnerability in Pay With MetaMask For WooCommerce – Cryptocurrency Payment Gateway <= 1.7.2 versions.
Internet-facing
14 days
Internal
60 days
- Not known to be exploited
- Can be exploited automatically
- Gives an attacker partial control
Type
CWE-345Insufficient Verification of Data Authenticity
Timeline
Published10 Oct 2026
Updated26 Oct 2026
First seen10 Oct 2026
Track software like this
Free during beta