Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
8.8
CVE-2026-107328: Langflow OSS lets logged‑in attacker run code remotely
CVE-2026-107328 · published 4 days ago
Summary
Versions 1.0.0 to 1.12.4 of IBM Langflow OSS can let someone who has an account execute their own code on the server. This could let the attacker take control of the system or steal data. Apply the latest update from IBM or restrict access to trusted users until you can upgrade.
What to do
- Update langflow langflow to version 1.12.5 or later.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| ibm | langflow oss | <= 1.12.4 |
| langflow | langflow |
>= 1.0.0, < 1.12.5 cpe:2.3:a:langflow:langflow:*:*:*:*:*:*:*:* |
Original advisory text
Langflow OSS is affected by multiple vulnerabilities
IBM Langflow OSS 1.0.0 through 1.12.4 could allow a remote authenticated attacker to execute arbitrary code due to improper neutralization of code in eval/exec.
References
- https://www.ibm.com/support/pages/node/7293016 Patch Vendor Advisory
Internet-facing
14 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit
- Gives an attacker full control
Severity
8.8
High
Type
CWE-94Code Injection
Timeline
Published29 Oct 2026
Updated31 Oct 2026
First seen29 Oct 2026
Track software like this
Free during beta