Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
9.8
CVE-2026-104317: Langflow OSS could let attacker run code
CVE-2026-104317 · published 4 days ago
Summary
Versions of Langflow OSS from 1.0.0 to 1.12.3 may let a remote user who can reach its message system execute any program on the server. This happens because the software processes data it shouldn’t trust. Protect the system by upgrading to a newer, fixed release and limit network access to the message broker.
What to do
- Update langflow langflow to version 1.12.4 or later.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| ibm | langflow oss | <= 1.12.3 |
| langflow | langflow |
>= 1.0.0, < 1.12.4 cpe:2.3:a:langflow:langflow:*:*:*:*:*:*:*:* |
Original advisory text
Langflow OSS is affected by multiple vulnerabilities
IBM Langflow OSS 1.0.0 through 1.12.3 could allow a remote attacker who could reach the message broker to execute arbitrary code on the system due to the deserialization of untrusted data.
References
- https://www.ibm.com/support/pages/node/7293015 Patch Vendor Advisory
Internet-facing
14 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit
- Gives an attacker full control
Severity
9.8
Critical
Type
CWE-502Deserialization of Untrusted Data
Timeline
Published29 Oct 2026
Updated31 Oct 2026
First seen29 Oct 2026
Track software like this
Free during beta