Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
7.9
CVE-2026-10275: OpenSC pkcs11-tool may overflow memory when generating keys
CVE-2026-10275 · published 5 months ago
Summary
Versions of OpenSC up to 0.26.1, including the packages provided by Debian, Ubuntu and BellSoft, have a flaw in the part of the tool that creates keys. An attacker who can trigger the tool from a distance could cause it to write more data than it can hold, potentially crashing the program or allowing further control, although the attack is difficult to carry out. Apply the supplied patch promptly to fix the problem.
What to do
- Update debian opensc to version 0.27.1-2.
- Update bellsoft opensc to version 0.27.1-r1.
Affected software
| Ecosystem | Vendor | Product | Affected versions |
|---|---|---|---|
| Debian:11 | debian | opensc | All versions |
| Debian:12 | debian | opensc | All versions |
| Debian:13 | debian | opensc | All versions |
| Ubuntu:Pro:16.04:LTS | canonical | opensc | All versions |
| Ubuntu:Pro:18.04:LTS | canonical | opensc | All versions |
| Ubuntu:Pro:20.04:LTS | canonical | opensc | All versions |
| Ubuntu:Pro:22.04:LTS | canonical | opensc | All versions |
| Ubuntu:Pro:24.04:LTS | canonical | opensc | All versions |
| Ubuntu:25.10 | canonical | opensc | All versions |
| Ubuntu:26.04:LTS | canonical | opensc | All versions |
| Debian:14 | debian | opensc |
< 0.27.1-2 Fix: upgrade to 0.27.1-2
|
| Alpaquita:23 | bellsoft | opensc |
>= 0.22.0-r4, < 0.27.1-r1 Fix: upgrade to 0.27.1-r1
|
| Alpaquita:25 | bellsoft | opensc |
>= 0.26.0-r0, < 0.27.1-r1 Fix: upgrade to 0.27.1-r1
|
| Alpaquita:stream | bellsoft | opensc |
>= 0.22.0-r3, < 0.27.1-r1 Fix: upgrade to 0.27.1-r1
|
Original advisory text
OpenSC pkcs11-tool Key Generation pkcs11-tool.c test_kpgen_certwrite buffer overflow
A flaw has been found in OpenSC up to 0.26.1. This affects the function test_kpgen_certwrite of the file src/tools/pkcs11-tool.c of the component pkcs11-tool Key Generation Module. This manipulation causes buffer overflow. The attack is possible to be carried out remotely. The complexity of an attack is rather high. It is indicated that the exploitability is difficult. The exploit has been published and may be used. Patch name: 814f745b3b6d100295f65f1935edd33d520d33ab. It is recommended to apply a patch to fix this issue.
References
- https://security-tracker.debian.org/tracker/CVE-2026-10275 Vendor Advisory
- https://ubuntu.com/security/CVE-2026-10275 Third Party Advisory
- https://www.cve.org/CVERecord?id=CVE-2026-10275 Third Party Advisory
- https://docs.bell-sw.com/security/cves/CVE-2026-10275 Vendor Advisory
- https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/10xxx/CVE-2026-10275... Vendor Advisory
- https://nvd.nist.gov/vuln/detail/CVE-2026-10275 Vendor Advisory
- https://github.com/OpenSC/OpenSC/ URL
- https://github.com/OpenSC/OpenSC/issues/3682 Third Party Advisory
- https://github.com/OpenSC/OpenSC/commit/814f745b3b6d100295f65f1935edd33d520d33ab Patch
- https://github.com/OpenSC/OpenSC/pull/3684 Patch
- https://vuldb.com/cve/CVE-2026-10275 Vendor Advisory
- https://vuldb.com/submit/825403 Vendor Advisory
- https://vuldb.com/vuln/367568 Vendor Advisory
- https://vuldb.com/vuln/367568/cti Third Party Advisory
- https://pan.baidu.com/s/1nrZPKDz2eAcCpsaFiIRlrg Exploit
Internet-facing
60 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit
- Gives an attacker partial control
Type
CWE-119Buffer Overflow
CWE-120Classic Buffer Overflow
Timeline
Published1 Jun 2026
Updated3 Nov 2026
First seen1 Jun 2026
Sources
CVE-2026-10275 · NVD
DEBIAN-CVE-2026-10275 · OSV
UBUNTU-CVE-2026-10275 · OSV
BELL-CVE-2026-10275 · OSV
CVE-2026-10275 · OSV
Track software like this
Free during beta