Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
6.5

CVE-2026-0885: Firefox and Thunderbird may let malicious code run

CVE-2026-0885 · published 9 months ago
Summary

A memory handling bug in the JavaScript engine of Firefox, Firefox ESR, Thunderbird and their Linux packages can let a crafted web page or email cause the program to execute unwanted code. This could let an attacker take control of the browser or email client and access data. Install the latest updates (Firefox 147 or newer, Firefox ESR 140.7 or newer, Thunderbird 147 or newer, Thunderbird 140.7 or newer) to fix the problem.

What to do
  • Update debian firefox-esr to version 140.7.0esr-1~deb11u1.
  • Update debian firefox-esr to version 140.7.0esr-1~deb12u1.
  • Update debian firefox-esr to version 140.7.0esr-1~deb13u1.
  • Update debian firefox-esr to version 140.7.0esr-1.
  • Update debian thunderbird to version 1:140.7.0esr-1~deb11u1.
  • Update debian thunderbird to version 1:140.7.0esr-1~deb12u1.
  • Update debian thunderbird to version 1:140.7.0esr-1~deb13u1.
  • Update canonical thunderbird to version 1:140.7.1+build1-0ubuntu0.22.04.1.
  • Update debian thunderbird to version 1:140.7.0esr-1.
Affected software
Ecosystem VendorProductAffected versions
– mozilla firefox < 140.7.0
< 147.0
cpe:2.3:a:mozilla:firefox:*:*:*:*:esr:*:*:*
– mozilla thunderbird < 140.7.0
< 147.0
cpe:2.3:a:mozilla:thunderbird:*:*:*:*:esr:*:*:*
Debian:11 debian firefox-esr < 140.7.0esr-1~deb11u1
Fix: upgrade to 140.7.0esr-1~deb11u1
Debian:12 debian firefox-esr < 140.7.0esr-1~deb12u1
Fix: upgrade to 140.7.0esr-1~deb12u1
Debian:13 debian firefox-esr < 140.7.0esr-1~deb13u1
Fix: upgrade to 140.7.0esr-1~deb13u1
Debian:14 debian firefox-esr < 140.7.0esr-1
Fix: upgrade to 140.7.0esr-1
Debian:11 debian thunderbird < 1:140.7.0esr-1~deb11u1
Fix: upgrade to 1:140.7.0esr-1~deb11u1
Debian:12 debian thunderbird < 1:140.7.0esr-1~deb12u1
Fix: upgrade to 1:140.7.0esr-1~deb12u1
Debian:13 debian thunderbird < 1:140.7.0esr-1~deb13u1
Fix: upgrade to 1:140.7.0esr-1~deb13u1
Ubuntu:18.04:LTS canonical mozjs52 All versions
Ubuntu:18.04:LTS canonical mozjs38 All versions
Ubuntu:20.04:LTS canonical mozjs68 All versions
Ubuntu:22.04:LTS canonical mozjs102 All versions
Ubuntu:22.04:LTS canonical mozjs78 All versions
Ubuntu:22.04:LTS canonical mozjs91 All versions
Ubuntu:22.04:LTS canonical thunderbird < 1:140.7.1+build1-0ubuntu0.22.04.1
Fix: upgrade to 1:140.7.1+build1-0ubuntu0.22.04.1
Ubuntu:24.04:LTS canonical mozjs115 All versions
Debian:14 debian thunderbird < 1:140.7.0esr-1
Fix: upgrade to 1:140.7.0esr-1
Original advisory text
Use-after-free in the JavaScript: GC component. This vulnerability was fixed in Firefox 147, Firefox ESR 140.7, Thunderbird 147, and Thunderbird 140.7.
Use-after-free in the JavaScript: GC component. This vulnerability was fixed in Firefox 147, Firefox ESR 140.7, Thunderbird 147, and Thunderbird 140.7.
Fix within
Internet-facing 14 days
Internal 60 days
  • Not known to be exploited
  • Can be exploited automatically
  • Gives an attacker partial control
Severity
6.5 Medium
Exploitation
<1% chance of attack within 30 days
Type
CWE-416Use After Free
Timeline
Published13 Jan 2026
Updated4 Nov 2026
First seen7 Mar 2026
Track software like this
Free during beta