Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
8.6

CVE-2026-0719: libsoup on Linux can crash from long passwords

CVE-2026-0719 · published 10 months ago
Summary

The libsoup library used in Debian and Red Hat Enterprise Linux versions can mishandle very long passwords during NTLM authentication, causing memory errors that may crash the program. This crash can stop the application from working, leading to a denial‑of‑service condition. Update the affected Linux packages to the latest versions that include the fix, or limit password length until the update is applied.

What to do
  • Update debian rootio-libsoup3 to version 3.6.5-3.root.io.1.
  • Update debian libsoup3 to version 3.6.5-3.aikido.5.
  • Update debian rootio-libsoup3 to version 3.6.5-3.aikido.5.
  • Update debian libsoup3 to version 3.6.5-3.root.io.2.
  • Update debian rootio-libsoup3 to version 3.6.5-3.root.io.2.
  • Update libsoup2.4 to version 2.74.3-1+deb12u1.aikido.5.
  • Update rootio-libsoup2.4 to version 2.74.3-1+deb12u1.aikido.5.
  • Update libsoup3 to version 3.6.5-3.aikido.8.
  • Update rootio-libsoup3 to version 3.6.5-3.aikido.8.
  • Update debian libsoup3 to version 3.8.0-1.
  • Update libsoup3 to version 3.6.5-3.aikido.9.
  • Update rootio-libsoup3 to version 3.6.5-3.aikido.9.
Affected software
Ecosystem VendorProductAffected versions
Root:Debian:13 debian rootio-libsoup3 < 3.6.5-3.root.io.1
< 3.6.5-3.aikido.5
< 3.6.5-3.root.io.2
Fix: upgrade to 3.6.5-3.root.io.1
– red hat red hat enterprise linux 10 All versions
– red hat red hat enterprise linux 10.0 extended update support All versions
– red hat red hat enterprise linux 7 extended lifecycle support All versions
– red hat red hat enterprise linux 8 All versions
– red hat red hat enterprise linux 8.2 advanced update support All versions
– red hat red hat enterprise linux 8.4 advanced mission critical update support All versions
– red hat red hat enterprise linux 8.4 extended update support long-life add-on All versions
– red hat red hat enterprise linux 8.6 advanced mission critical update support All versions
– red hat red hat enterprise linux 8.6 telecommunications update service All versions
– red hat red hat enterprise linux 8.6 update services for sap solutions All versions
– red hat red hat enterprise linux 8.8 telecommunications update service All versions
– red hat red hat enterprise linux 8.8 update services for sap solutions All versions
– red hat red hat enterprise linux 9 All versions
– red hat red hat enterprise linux 9.0 update services for sap solutions All versions
– red hat red hat enterprise linux 9.2 update services for sap solutions All versions
– red hat red hat enterprise linux 9.4 extended update support All versions
– red hat red hat enterprise linux 9.6 extended update support All versions
– red hat red hat openshift dev spaces (rhosds) 3.26 All versions
– red hat red hat enterprise linux 6 All versions
Debian:11 debian libsoup2.4 All versions
Debian:12 debian libsoup2.4 All versions
Debian:13 debian libsoup2.4 All versions
Debian:12 debian libsoup3 All versions
Debian:13 debian libsoup3 All versions
Root:Debian:13 debian libsoup3 < 3.6.5-3.aikido.5
< 3.6.5-3.root.io.2
Fix: upgrade to 3.6.5-3.aikido.5
Debian:14 debian libsoup3 < 3.8.0-1
Fix: upgrade to 3.8.0-1
Root:Debian:12 – libsoup2.4 < 2.74.3-1+deb12u1.aikido.5
Fix: upgrade to 2.74.3-1+deb12u1.aikido.5
Root:Debian:12 – rootio-libsoup2.4 < 2.74.3-1+deb12u1.aikido.5
Fix: upgrade to 2.74.3-1+deb12u1.aikido.5
Ubuntu:Pro:16.04:LTS canonical libsoup2.4 All versions
Ubuntu:Pro:22.04:LTS canonical libsoup3 All versions
Root:Debian:13 – libsoup3 < 3.6.5-3.aikido.8
< 3.6.5-3.aikido.9
Fix: upgrade to 3.6.5-3.aikido.8
Root:Debian:13 – rootio-libsoup3 < 3.6.5-3.aikido.8
< 3.6.5-3.aikido.9
Fix: upgrade to 3.6.5-3.aikido.8
Original advisory text
Libsoup: signed to unsigned conversion error leading to stack-based buffer overflow in libsoup ntlm authentication
A flaw was identified in the NTLM authentication handling of the libsoup HTTP library, used by GNOME and other applications for network communication. When processing extremely long passwords, an internal size calculation can overflow due to improper use of signed integers. This results in incorrect memory allocation on the stack, followed by unsafe memory copying. As a result, applications using libsoup may crash unexpectedly, creating a denial-of-service risk.
Fix within
Internet-facing 14 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit
  • Gives an attacker full control
Severity
8.6 High
Exploitation
<1% chance of attack within 30 days
Type
CWE-121Stack-based Buffer Overflow
Timeline
Published8 Jan 2026
Updated4 Nov 2026
First seen6 Mar 2026
Track software like this
Free during beta