Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
8.3
CVE-2025-8869: pip can be tricked into running unwanted code
CVE-2025-8869 · published 2 days ago
Summary
The Python package installer pip has a flaw that could let an attacker cause it to run malicious commands when packages are installed. Updated versions from the pip developers and the Debian packages have been released to fix the issue. Apply the latest pip update as soon as possible to protect your systems.
What to do
- Update the pip developers pip to version 25.3.
- Update rootio-pip to version 22.0.4+root.io.3.
- Update rootio-pip to version 25.0.1+root.io.2.
- Update rootio-pip to version 25.2+root.io.2.
- Update the pip developers pip to version 22.3.1+aikido.4.
- Update rootio-pip to version 22.3.1+root.io.4.
- Update pip to version 22.0.4+aikido.5.
- Update debian python-pip to version 23.0.1+dfsg-1.root.io.2.
- Update debian rootio-python-pip to version 23.0.1+dfsg-1.root.io.2.
- Update debian python-pip to version 20.3.4-4+deb11u2.
- Update debian python-pip to version 25.3+dfsg-1.
- Update pip to version 24.2+aikido.4.
Affected software
| Ecosystem | Vendor | Product | Affected versions |
|---|---|---|---|
| pip | the pip developers | pip |
<= 25.2 Fix: upgrade to 25.3
|
| PyPI | the pip developers | pip |
< 25.3 Fix: upgrade to 25.3
|
| Root:PyPI | – | rootio-pip |
< 22.0.4+root.io.3 < 25.0.1+root.io.2 < 25.2+root.io.2 < 22.3.1+root.io.4 Fix: upgrade to 22.0.4+root.io.3
|
| Root:PyPI | the pip developers | pip |
< 22.3.1+aikido.4 Fix: upgrade to 22.3.1+aikido.4
|
| Root:PyPI | – | pip |
< 22.0.4+aikido.5 < 24.2+aikido.4 Fix: upgrade to 22.0.4+aikido.5
|
| Root:Debian:12 | debian | python-pip |
< 23.0.1+dfsg-1.root.io.2 Fix: upgrade to 23.0.1+dfsg-1.root.io.2
|
| Root:Debian:12 | debian | rootio-python-pip |
< 23.0.1+dfsg-1.root.io.2 Fix: upgrade to 23.0.1+dfsg-1.root.io.2
|
| Debian:11 | debian | python-pip |
< 20.3.4-4+deb11u2 Fix: upgrade to 20.3.4-4+deb11u2
|
| Debian:12 | debian | python-pip | All versions |
| Debian:13 | debian | python-pip | All versions |
| Debian:14 | debian | python-pip |
< 25.3+dfsg-1 Fix: upgrade to 25.3+dfsg-1
|
Original advisory text
CVE-2025-8869 in pip - Patched by Root
Root has patched CVE-2025-8869 in the pip package for Root:PyPI. Multiple fixed versions available.
References
- https://mail.python.org/archives/list/[email protected]/thread/IF5A3G...
- https://github.com/pypa/pip/commit/f2b92314da012b9fffa36b3f3e67748a37ef464a
- https://pip.pypa.io/en/stable/news/#v25-2
- https://github.com/advisories/GHSA-4xh5-x5gv-qwph
- https://nvd.nist.gov/vuln/detail/CVE-2025-8869 Vendor Advisory
- https://github.com/pypa/pip Product
- https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/8xxx/CVE-2025-8869.j... Vendor Advisory
- https://pypi.org/project/pip Product
- https://github.com/pypa/pip/pull/13550 Patch
- https://lists.debian.org/debian-lts-announce/2025/10/msg00028.html URL
- https://mail.python.org/archives/list/[email protected]/thread/IF5A3G... Vendor Advisory
- https://security-tracker.debian.org/tracker/CVE-2025-8869 Vendor Advisory
Internet-facing
60 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit
- Gives an attacker partial control
Type
CWE-59Link Following
Timeline
Published2 Nov 2026
Updated3 Nov 2026
First seen6 Mar 2026
Sources
GHSA-4xh5-x5gv-qwph · GHSA
CVE-2025-8869 · NVD
CVE-2025-8869 · OSV
DEBIAN-CVE-2025-8869 · OSV
Track software like this
Free during beta