Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
4.3
CVE-2025-8091: EventON Lite Plugin Exposes Sensitive Post Data on WordPress
CVE-2025-8091 · published 1 year ago
Summary
The EventON Lite plugin for WordPress allows unauthorized users to access private, password-protected, or draft posts through its shortcodes. This means sensitive information can be exposed. Update to version 2.4.7 or higher to fix the issue.
Original advisory text
The EventON Lite plugin for WordPress is vulnerable to Information Exposure in all versions less than, or equal to, 2.4.6 via the add_single_eventon and add_eventon shortcodes due to insufficient r...
The EventON Lite plugin for WordPress is vulnerable to Information Exposure in all versions less than, or equal to, 2.4.6 via the add_single_eventon and add_eventon shortcodes due to insufficient restrictions on which posts can be included. This makes it possible for unauthenticated attackers to extract data from password protected, private, or draft posts that they should not have access to.
References
- https://plugins.trac.wordpress.org/browser/eventon-lite/trunk/includes/calendar/...
- https://plugins.trac.wordpress.org/browser/eventon-lite/trunk/includes/class-eve...
- https://plugins.trac.wordpress.org/browser/eventon-lite/trunk/includes/class-evo...
- https://plugins.trac.wordpress.org/browser/eventon-lite/trunk/includes/class-evo...
- https://wordpress.org/plugins/eventon-lite/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/421fcee2-a05d-4486-837...
Internet-facing
60 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit
- Gives an attacker partial control
Type
CWE-200Information Exposure
Timeline
Published15 Aug 2025
Updated4 Nov 2026
First seen7 Mar 2026
Sources
CVE-2025-8091 · NVD
Track software like this
Free during beta