Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
9.8
CVE-2025-63665: GT Edge AI Community Edition allows code injection via crafted prompt
CVE-2025-63665 · published 10 months ago
Summary
The GT Edge AI Community Edition is vulnerable to a security risk that allows attackers to execute malicious code. This could happen if a user enters a specially crafted prompt, which is a piece of text that the AI uses to generate a response. To stay safe, update to the latest version, v2.0.12, or take other security measures to prevent untrusted users from accessing the Prompt window.
What to do
- Update gtedge gt_edge_ai to version 2.0.12 or later.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| gtedge | gt_edge_ai |
< 2.0.12 cpe:2.3:a:gtedge:gt_edge_ai:*:*:*:*:community:*:*:* |
Original advisory text
An issue in GT Edge AI Community Edition Versions before v2.0.12 allows attackers to execute arbitrary code via injecting a crafted JSON payload into the Prompt window.
An issue in GT Edge AI Community Edition Versions before v2.0.12 allows attackers to execute arbitrary code via injecting a crafted JSON payload into the Prompt window.
References
- https://gist.github.com/p80n-sec/e5eefcef155e9dd14aaaaa49f9f94cd1 Third Party Advisory
- https://github.com/p80n-sec/Vulnerability-Research/blob/main/CVE-2025-63665/CVE-... Third Party Advisory
Internet-facing
3 days
Internal
60 days
- Not known to be exploited
- Can be exploited automatically
- Gives an attacker full control
Type
CWE-94Code Injection
Timeline
Published19 Dec 2025
Updated4 Nov 2026
First seen7 Mar 2026
Sources
CVE-2025-63665 · NVD
Track software like this
Free during beta