Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
5.3
CVE-2025-62109: Geo Controller: Sensitive Data Leaked from Unpatched Versions
CVE-2025-62109 · published 11 months ago
Summary
If you're using an outdated version of Geo Controller (8.9.4 or earlier), a security issue could allow an attacker to access sensitive information that was meant to be secure. This means that if you haven't updated your Geo Controller, you should do so as soon as possible to prevent potential data breaches. Update to version 8.9.5 or later to fix the issue.
Original advisory text
Insertion of Sensitive Information Into Sent Data vulnerability in INFINITUM FORM Geo Controller cf-geoplugin allows Retrieve Embedded Sensitive Data.This issue affects Geo Controller: from n/a thr...
Insertion of Sensitive Information Into Sent Data vulnerability in INFINITUM FORM Geo Controller cf-geoplugin allows Retrieve Embedded Sensitive Data.This issue affects Geo Controller: from n/a through <= 8.9.4.
Internet-facing
14 days
Internal
60 days
- Not known to be exploited
- Can be exploited automatically
- Gives an attacker partial control
Severity
5.3
Medium
Type
CWE-201Insertion of Sensitive Information Into Sent Data
Timeline
Published9 Dec 2025
Updated3 Nov 2026
First seen7 Mar 2026
Sources
CVE-2025-62109 · NVD
Track software like this
Free during beta