Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
7.9
CVE-2025-61916: Spinnaker: Server-Side Request Forgery in User-Input Enabled Artifacts
CVE-2025-61916 · published 10 months ago
Summary
Spinnaker versions prior to 2025.1.6, 2025.2.3, and 2025.3.0 allow attackers to fetch sensitive data from remote URLs and inject it into pipelines, potentially exposing credentials. To be vulnerable, your Spinnaker installation must have user-input enabled artifacts and be set up to consume their output. To fix, update to the latest version or, as a temporary workaround, disable user-input enabled artifacts.
What to do
- Update spinnaker io.spinnaker.clouddriver:clouddriver-artifacts to version 2025.1.6.
- Update spinnaker io.spinnaker.clouddriver:clouddriver-artifacts to version 2025.2.3.
Affected software
| Ecosystem | Vendor | Product | Affected versions |
|---|---|---|---|
| – | linuxfoundation | spinnaker |
< 2025.1.6 >= 2025.2.0, < 2025.2.3 cpe:2.3:a:linuxfoundation:spinnaker:*:*:*:*:*:*:*:* |
| maven | spinnaker | io.spinnaker.clouddriver:clouddriver-artifacts |
< 2025.1.6 >= 2025.2.0, < 2025.2.3 Fix: upgrade to 2025.1.6
|
Original advisory text
Spinnaker vulnerable to SSRF due to improper restrictions on http from user input
Spinnaker is an open source, multi-cloud continuous delivery platform. Versions prior to 2025.1.6, 2025.2.3, and 2025.3.0 are vulnerable to server-side request forgery. The primary impact is allowing users to fetch data from a remote URL. This data can be then injected into spinnaker pipelines via helm or other methods to extract things LIKE idmsv1 authentication data. This also includes calling internal spinnaker API's via a get and similar endpoints. Further, depending upon the artifact in question, auth data may be exposed to arbitrary endpoints (e.g. GitHub auth headers) leading to credentials exposure. To trigger this, a spinnaker installation MUST have two things. The first is an artifact enabled that allows user input. This includes GitHub file artifacts, BitBucket, GitLab, HTTP artifacts and similar artifact providers. JUST enabling the http artifact provider will add a "no-auth" http provider that could be used to extract link local data (e.g. AWS Metadata information). The second is a system that can consume the output of these artifacts. e.g. Rosco helm can use this to fetch values data. K8s account manifests if the API returns JSON can be used to inject that data into the pipeline itself though the pipeline would fail. This vulnerability is fixed in versions 2025.1.6, 2025.2.3, and 2025.3.0. As a workaround, disable HTTP account types that allow user input of a given URL. This is probably not feasible in most cases. Git, Docker and other artifact account types with explicit URL configurations bypass this limitation and should be safe as they limit artifact URL loading. Alternatively, use one of the various vendors which provide OPA policies to restrict pipelines from accessing or saving a pipeline with invalid URLs.
References
- https://github.com/advisories/GHSA-vrjc-q2fh-6x9h
- https://github.com/spinnaker/spinnaker/security/advisories/GHSA-vrjc-q2fh-6x9h Vendor Advisory
- https://nvd.nist.gov/vuln/detail/CVE-2025-61916 Vendor Advisory
- https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/61xxx/CVE-2025-61916... Vendor Advisory
Internet-facing
60 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit
- Gives an attacker partial control
Severity
7.9
High
Type
CWE-20Improper Input Validation
CWE-523Unprotected Transport of Credentials
CWE-918Server-Side Request Forgery (SSRF)
Timeline
Published5 Jan 2026
Updated27 Oct 2026
First seen6 Mar 2026
Track software like this
Free during beta