Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
5.9
CVE-2025-58114: BlueSpice CognitiveProcessDesigner allows malicious code injection
CVE-2025-58114 · published 1 year ago
Summary
An attacker can inject malicious code into BlueSpice, potentially allowing them to take control of a user's account or steal sensitive information. This affects BlueSpice versions 5 to 5.1.1. Upgrade to the latest version to fix the issue.
What to do
- Update hallowelt bluespice to version 5.1.2 or later.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| hallowelt | bluespice |
>= 5.0, < 5.1.2 cpe:2.3:a:hallowelt:bluespice:*:*:*:*:*:*:*:* |
Original advisory text
Improper Input Validation vulnerability in Hallo Welt! GmbH BlueSpice (Extension:CognitiveProcessDesigner) allows Cross-Site Scripting (XSS).This issue affects BlueSpice: from 5 through 5.1.1.
Improper Input Validation vulnerability in Hallo Welt! GmbH BlueSpice (Extension:CognitiveProcessDesigner) allows Cross-Site Scripting (XSS).This issue affects BlueSpice: from 5 through 5.1.1.
References
Internet-facing
60 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit
- Gives an attacker partial control
Type
CWE-20Improper Input Validation
CWE-79Cross-site Scripting (XSS)
Timeline
Published19 Sep 2025
Updated3 Nov 2026
First seen7 Mar 2026
Sources
CVE-2025-58114 · NVD
Track software like this
Free during beta