Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
9.4

CVE-2025-58046: Dataease Impala Datasource Allows Remote Code Execution

CVE-2025-58046 · published 1 year ago
Summary

Dataease, a data analysis platform, has a security flaw in its Impala data source. This flaw allows hackers to execute commands on your system remotely, which could lead to data breaches or system crashes. To fix this, upgrade to the latest version of Dataease, specifically version 2.10.13 or later.

What to do
  • Update dataease dataease to version 2.10.13 or later.
Affected software
VendorProductAffected versions
dataease dataease < 2.10.13
cpe:2.3:a:dataease:dataease:*:*:*:*:*:*:*:*
Original advisory text
Dataease has a JDBC attack vulnerability in the Impala datasource
Dataease is an open-source data visualization and analysis platform. In versions up to and including 2.10.12, the Impala data source is vulnerable to remote code execution due to insufficient filtering in the getJdbc method of the io.dataease.datasource.type.Impala class. Attackers can construct malicious JDBC connection strings that exploit JNDI injection and trigger RMI deserialization, ultimately enabling remote command execution. The vulnerability can be exploited by editing the data source and providing a crafted JDBC connection string that references a remote configuration file, leading to RMI-based deserialization attacks. This issue has been patched in version 2.10.13. It is recommended to upgrade to the latest version. No known workarounds exist for affected versions.
Fix within
Internet-facing 3 days
Internal 60 days
  • Not known to be exploited
  • Can be exploited automatically
  • Gives an attacker full control
Severity
9.4 Critical
Exploitation
1% chance of attack within 30 days
Type
CWE-502Deserialization of Untrusted Data
CWE-74Injection
Timeline
Published15 Sep 2025
Updated31 Oct 2026
First seen15 Jul 2026
Sources
CVE-2025-58046 · NVD
Track software like this
Free during beta