Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
1.3
CVE-2025-57709: Qsync Central: Unauthenticated User Can Crash Processes or Modify Memory
CVE-2025-57709 · published 8 months ago
Summary
Qsync Central users should update to version 5.0.0.4 or later to prevent unauthorized actions by remote attackers. This update fixes a security issue that allowed attackers to manipulate system resources. Update as soon as possible to ensure your system remains secure.
What to do
- Update qnap qsync_central to version 5.0.0.4 or later.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| qnap | qsync_central |
>= 5.0.0.0, < 5.0.0.4 cpe:2.3:a:qnap:qsync_central:*:*:*:*:*:*:*:* |
Original advisory text
A buffer overflow vulnerability has been reported to affect Qsync Central. If a remote attacker gains a user account, they can then exploit the vulnerability to modify memory or crash processes.
W...
A buffer overflow vulnerability has been reported to affect Qsync Central. If a remote attacker gains a user account, they can then exploit the vulnerability to modify memory or crash processes.
We have already fixed the vulnerability in the following version:
Qsync Central 5.0.0.4 ( 2026/01/20 ) and later
We have already fixed the vulnerability in the following version:
Qsync Central 5.0.0.4 ( 2026/01/20 ) and later
References
- https://www.qnap.com/en/security-advisory/qsa-26-02 Vendor Advisory
Internet-facing
60 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit
- Gives an attacker partial control
Type
CWE-122Heap-based Buffer Overflow
CWE-787Out-of-bounds Write
Timeline
Published11 Feb 2026
Updated4 Nov 2026
First seen6 Mar 2026
Sources
CVE-2025-57709 · NVD
Track software like this
Free during beta