Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
8.8

CVE-2025-53510: Adobe SAIL Image Decoding Library v0.9.8: Remote Code Execution through Malicious PSD File

CVE-2025-53510 · published 1 year ago
Summary

A bug in the SAIL Image Decoding Library v0.9.8 can allow hackers to take control of a computer if a specially crafted Adobe PSD file is loaded. This can happen if a user is tricked into opening a malicious file. To protect against this, make sure to update the library to the latest version or use a different image decoding library.

What to do
  • Update debian sail to version 0.9.8-1+deb13u1.
Affected software
Ecosystem VendorProductAffected versions
– sail sail 0.9.8
cpe:2.3:a:sail:sail:0.9.8:*:*:*:*:*:*:*
Debian:13 debian sail < 0.9.8-1+deb13u1
Fix: upgrade to 0.9.8-1+deb13u1
Ubuntu:24.04:LTS canonical sail All versions
Original advisory text
A memory corruption vulnerability exists in the PSD Image Decoding functionality of the SAIL Image Decoding Library v0.9.8. When loading a specially crafted .psd file, an integer overflow can be ma...
A memory corruption vulnerability exists in the PSD Image Decoding functionality of the SAIL Image Decoding Library v0.9.8. When loading a specially crafted .psd file, an integer overflow can be made to occur when calculating the stride for decoding. Afterwards, this will cause a heap-based buffer to overflow when decoding the image which can lead to remote code execution. An attacker will need to convince the library to read a file to trigger this vulnerability.
Fix within
Internet-facing 14 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit
  • Gives an attacker full control
Severity
8.8 High
Exploitation
<1% chance of attack within 30 days
Type
CWE-680Integer Overflow to Buffer Overflow
Timeline
Published25 Aug 2025
Updated4 Nov 2026
First seen7 Mar 2026
Track software like this
Free during beta