Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
6.5
CVE-2025-53202: CyberChimps Responsive Blocks can let attackers run code
CVE-2025-53202 · published 1 year ago
Summary
The Responsive Blocks add‑on for CyberChimps websites does not properly clean user input when it builds pages, allowing a type of attack called DOM‑based cross‑site scripting. An attacker could inject malicious script that runs in a visitor’s browser, potentially stealing data or altering the page. Update the add‑on to version 2.0.7 or later, or remove it if you cannot apply the update, and ensure any custom code also validates input.
Original advisory text
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in CyberChimps Responsive Blocks responsive-block-editor-addons allows DOM-Based XSS.This issue af...
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in CyberChimps Responsive Blocks responsive-block-editor-addons allows DOM-Based XSS.This issue affects Responsive Blocks: from n/a through <= 2.0.6.
Internet-facing
60 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit
- Gives an attacker partial control
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published27 Jun 2025
Updated31 Oct 2026
First seen7 Mar 2026
Sources
CVE-2025-53202 · NVD
Track software like this
Free during beta