Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
6.1
CVE-2025-51501: Microweber CMS 2.0: Arbitrary JavaScript Execution Through API Endpoint
CVE-2025-51501 · published 1 year ago
Summary
A security weakness in Microweber CMS 2.0 could allow hackers to inject malicious code into the website. This could lead to unauthorized actions and data theft. To protect your site, update Microweber CMS 2.0 to the latest version.
What to do
The CVE record does not list a fixed version. Check the vendor's site or the advisory links below - a fix may already be released.
Affected software
| Ecosystem | Vendor | Product | Affected versions |
|---|---|---|---|
| composer | microweber | microweber | >= 2.0.0, <= 2.0.19 |
| – | microweber | microweber |
2.0.0 cpe:2.3:a:microweber:microweber:2.0.0:*:*:*:*:*:*:* |
Original advisory text
Reflected Cross-Site Scripting (XSS) in the id parameter of the live_edit.module_settings API endpoint in Microweber CMS2.0 allows execution of arbitrary JavaScript.
Reflected Cross-Site Scripting (XSS) in the id parameter of the live_edit.module_settings API endpoint in Microweber CMS2.0 allows execution of arbitrary JavaScript.
References
- https://github.com/advisories/GHSA-8357-fjvx-xrm8
- https://github.com/progprnv/CVE-Reports/blob/main/CVE-2025-51501 URL
- https://github.com/progprnv/CVE-Reports/blob/main/MICROWEBER%20%5BAdmin%20Panel%... URL
- https://nvd.nist.gov/vuln/detail/CVE-2025-51501 Vendor Advisory
- https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/51xxx/CVE-2025-51501... Vendor Advisory
- https://github.com/progprnv/CVE-Reports Product
Internet-facing
60 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit
- Gives an attacker partial control
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published1 Aug 2025
Updated4 Nov 2026
First seen6 Mar 2026
Track software like this
Free during beta