Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
6.1
CVE-2025-44595: Halo Archives XSS Allows Malicious Code Execution
CVE-2025-44595 · published 1 year ago
Summary
If an attacker tricks a Halo user into accessing a malicious archive link, they can inject and run arbitrary code on the victim's system. This is a serious risk because it allows attackers to steal sensitive information or take control of the system. Update to Halo version 2.20.18 or later to fix this issue.
What to do
The CVE record does not list a fixed version. Check the vendor's site or the advisory links below - a fix may already be released.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| halo | halo |
<= 2.20.17 cpe:2.3:a:halo:halo:*:*:*:*:*:*:*:* |
Original advisory text
Halo v2.20.17 and before is vulnerable to Cross Site Scripting (XSS) in /halo_host/archives/{name}.
Halo v2.20.17 and before is vulnerable to Cross Site Scripting (XSS) in /halo_host/archives/{name}.
Internet-facing
60 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit
- Gives an attacker partial control
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published9 Sep 2025
Updated4 Nov 2026
First seen7 Mar 2026
Track software like this
Free during beta