Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
4.9
CVE-2025-3430: 3DPrint Lite Plugin for WordPress: Malicious SQL Code Can Be Injected
CVE-2025-3430 · published 1 year ago
Summary
A security issue in the 3DPrint Lite plugin for WordPress allows hackers to inject malicious SQL code into the website's database without needing a password. This could allow them to access sensitive information. Update the plugin to the latest version, 2.1.3.7, to fix this issue.
What to do
- Update wp3dprinting 3dprint_lite to version 2.1.3.7 or later.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| wp3dprinting | 3dprint_lite |
< 2.1.3.7 cpe:2.3:a:wp3dprinting:3dprint_lite:*:*:*:*:*:wordpress:*:* |
Original advisory text
The 3DPrint Lite plugin for WordPress is vulnerable to SQL Injection via the 'printer_text' parameter in all versions up to, and including, 2.1.3.6 due to insufficient escaping on the user supplied...
The 3DPrint Lite plugin for WordPress is vulnerable to SQL Injection via the 'printer_text' parameter in all versions up to, and including, 2.1.3.6 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for unauthenticated attackers to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
Internet-facing
60 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit
- Gives an attacker partial control
Type
CWE-89SQL Injection
Timeline
Published8 Apr 2025
Updated4 Nov 2026
First seen7 Mar 2026
Sources
CVE-2025-3430 · NVD
Track software like this
Free during beta