Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
6.1

CVE-2025-3421: Everest Forms can run attacker scripts via crafted link

CVE-2025-3421 · published 1 year ago
Summary

The Everest Forms plugin for WordPress lets you build contact, quiz, survey, newsletter and payment forms. Because it does not properly clean the 'form_id' input, an attacker can embed malicious JavaScript that runs in a visitor's browser when they click a specially crafted link, potentially stealing data or hijacking sessions. Update the plugin to the latest version (3.1.2 or newer) or apply the vendor's patch and ensure any custom forms validate input.

What to do
  • Update wpeverest everest_forms to version 3.1.2 or later.
Affected software
VendorProductAffected versions
wpeverest everest_forms < 3.1.2
cpe:2.3:a:wpeverest:everest_forms:*:*:*:*:*:wordpress:*:*
Original advisory text
Everest Forms <= 3.1.1 - Reflected Cross-Site Scripting
The Everest Forms – Contact Form, Quiz, Survey, Newsletter & Payment Form Builder for WordPress plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'form_id' parameter in all versions up to, and including, 3.1.1 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
Fix within
Internet-facing 60 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit
  • Gives an attacker partial control
Severity
6.1 Medium
Exploitation
<1% chance of attack within 30 days
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published11 Apr 2025
Updated4 Nov 2026
First seen7 Mar 2026
Sources
CVE-2025-3421 · NVD
CVE-2025-3421 · OSV
Track software like this
Free during beta