Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
7.6

CVE-2025-32785: Pi-hole admin UI can run malicious code

CVE-2025-32785 · published 1 year ago
Summary

The web interface used to manage Pi-hole before version 6.3 lets a logged‑in user place JavaScript code into the Address field when editing a subscribed list. That code runs for any other user who later updates the block list, potentially stealing data or changing settings. Upgrade to version 6.3 or later to stop the problem.

What to do
  • Update pi-hole web_interface to version 6.3 or later.
Affected software
VendorProductAffected versions
pi-hole web_interface < 6.3
cpe:2.3:a:pi-hole:web_interface:*:*:*:*:*:*:*:*
Original advisory text
Pi-hole Admin Interface vulnerable to persistent XSS on Subscribed lists group management (Adress Field)
Pi-hole Admin Interface is a web interface for managing Pi-hole, a network-level advertisement and internet tracker blocking application. Pi-hole Admin Interface versions prior to 6.3 are vulnerable to cross-site scripting (XSS) via the Address field in the Subscribed Lists group management section. An authenticated user can inject malicious JavaScript by adding a payload to the Address field when creating or editing a list entry. The vulnerability is triggered when another user navigates to the Tools section and performs a gravity database update. The Address field does not properly sanitize input, allowing special characters and script tags to bypass validation. This has been patched in version 6.3.
Fix within
Internet-facing 60 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit
  • Gives an attacker partial control
Severity
7.6 High
Exploitation
<1% chance of attack within 30 days
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published27 Oct 2025
Updated4 Nov 2026
First seen7 Mar 2026
Sources
Track software like this
Free during beta