Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
5.4

CVE-2025-27914: Zimbra Collaboration (ZCS) allows attackers to inject malicious code

CVE-2025-27914 · published 1 year ago
Summary

Authenticated attackers can inject and execute JavaScript code in a user's session by sending a specially crafted URL to a victim. This could allow the attacker to access sensitive information or take control of the user's account. Zimbra administrators should update to the latest version of ZCS to fix this issue.

What to do
  • Update zimbra collaboration to version 10.0.11 or later.
Affected software
VendorProductAffected versions
zimbra collaboration >= 10.0.0, < 10.0.11
9.0.0
10.1.0
cpe:2.3:a:zimbra:collaboration:*:*:*:*:*:*:*:*
Original advisory text
An issue was discovered in Zimbra Collaboration (ZCS) 9.0 and 10.0 and 10.1. A Reflected Cross-Site Scripting (XSS) vulnerability exists in the /h/rest endpoint, allowing authenticated attackers to...
An issue was discovered in Zimbra Collaboration (ZCS) 9.0 and 10.0 and 10.1. A Reflected Cross-Site Scripting (XSS) vulnerability exists in the /h/rest endpoint, allowing authenticated attackers to inject and execute arbitrary JavaScript in a victim's session. Exploitation requires a valid auth token and involves a crafted URL with manipulated query parameters that triggers XSS when accessed by a victim.
Fix within
Internet-facing 60 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit
  • Gives an attacker partial control
Severity
5.4 Medium
Exploitation
<1% chance of attack within 30 days
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published12 Mar 2025
Updated3 Nov 2026
First seen7 Mar 2026
Sources
Track software like this
Free during beta