Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
6.5
CVE-2025-25137: Social Links Stored XSS: Attackers can inject malicious code
CVE-2025-25137 · published 1 year ago
Summary
The Social Links plugin for WordPress contains a security flaw that allows attackers to inject malicious code into web pages. If exploited, this could lead to unauthorized access or data theft. Update Social Links to version 1.0.12 or later to fix this issue.
What to do
The CVE record does not list a fixed version. Check the vendor's site or the advisory links below - a fix may already be released.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| kareemsultan | social links | <= 1.0.11 |
Original advisory text
Cross-Site Request Forgery (CSRF) vulnerability in kareemsultan Social Links social-links allows Cross Site Request Forgery.
This issue affects Social Links: from n/a through 1.0.11.
Cross-Site Request Forgery (CSRF) vulnerability in kareemsultan Social Links social-links allows Cross Site Request Forgery.
This issue affects Social Links: from n/a through 1.0.11.
This issue affects Social Links: from n/a through 1.0.11.
Internet-facing
60 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit
- Gives an attacker partial control
Type
CWE-79Cross-site Scripting (XSS)
CWE-352Cross-Site Request Forgery (CSRF)
Timeline
Published3 Mar 2025
Updated26 Oct 2026
First seen7 Mar 2026
Track software like this
Free during beta