Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
6.5

CVE-2025-23899: Bookalet lets attackers embed malicious code in pages

CVE-2025-23899 · published 1 year ago
Summary

The Bookalet web application does not properly clean user input when generating pages, allowing attackers to store harmful scripts that run in other users' browsers. This can lead to data theft, session hijacking, or defacement of the site. Update Bookalet to version 1.0.4 or later, or apply the vendor's recommended patch, and ensure input validation is enforced.

Original advisory text
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Bookalet Bookalet bookalet allows Stored XSS.This issue affects Bookalet: from n/a through <= 1...
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Bookalet Bookalet bookalet allows Stored XSS.This issue affects Bookalet: from n/a through <= 1.0.3.
Fix within
Internet-facing 60 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit
  • Gives an attacker partial control
Severity
6.5 Medium
Exploitation
<1% chance of attack within 30 days
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published16 Jan 2025
Updated4 Nov 2026
First seen7 Mar 2026
Sources
Track software like this
Free during beta