Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
7.1

CVE-2025-23879: Easy Automatic Newsletter Lite may let attackers run scripts in visitors' browsers

CVE-2025-23879 · published 1 year ago
Summary

The Easy Automatic Newsletter Lite plugin does not properly clean user-supplied data when generating pages, allowing a reflected cross‑site scripting attack. An attacker could craft a link that, when clicked, runs malicious code in a visitor’s browser, potentially stealing information or hijacking sessions. Update the plugin to version 3.2.1 or later, or apply the vendor’s patch, and avoid accepting untrusted input on pages that display user data.

Original advisory text
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in PillarDev Easy Automatic Newsletter Lite easy-automatic-newsletter allows Reflected XSS.This is...
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in PillarDev Easy Automatic Newsletter Lite easy-automatic-newsletter allows Reflected XSS.This issue affects Easy Automatic Newsletter Lite: from n/a through <= 3.2.0.
Fix within
Internet-facing 60 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit
  • Gives an attacker partial control
Severity
7.1 High
Exploitation
<1% chance of attack within 30 days
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published3 Mar 2025
Updated4 Nov 2026
First seen7 Mar 2026
Sources
Track software like this
Free during beta