Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
4.8
CVE-2025-22664: Ays Pro Survey Maker lets attackers inject malicious code
CVE-2025-22664 · published 1 year ago
Summary
The Survey Maker component in Ays Pro (versions up to 5.1.3.5) does not properly clean the data that users submit. As a result, an attacker could store harmful script code that runs in the browsers of anyone who views the survey, potentially stealing information or changing what the page shows. Update to the newest version or apply the vendor's patch and make sure all user input is filtered before being displayed.
What to do
- Update ays-pro survey_maker to version 5.1.3.6 or later.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| ays-pro | survey_maker |
< 5.1.3.6 cpe:2.3:a:ays-pro:survey_maker:*:*:*:*:*:wordpress:*:* |
Original advisory text
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Ays Pro Survey Maker survey-maker allows Stored XSS.This issue affects Survey Maker: from n/a t...
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Ays Pro Survey Maker survey-maker allows Stored XSS.This issue affects Survey Maker: from n/a through <= 5.1.3.5.
References
- https://patchstack.com/database/wordpress/plugin/survey-maker/vulnerability/word... Third Party Advisory
- https://patchstack.com/database/Wordpress/Plugin/survey-maker/vulnerability/word... Third Party Advisory
Internet-facing
60 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit
- Gives an attacker partial control
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published4 Feb 2025
Updated4 Nov 2026
First seen7 Mar 2026
Sources
CVE-2025-22664 · NVD
Track software like this
Free during beta