Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
5.4
CVE-2025-22315: WPDeveloper Typing Text lets attackers inject malicious scripts
CVE-2025-22315 · published 1 year ago
Summary
The Typing Text plugin for WordPress does not properly clean the text that users enter, allowing harmful code to be stored and later displayed on web pages. An attacker could use this to run scripts in visitors' browsers, potentially stealing data or hijacking sessions. Update the plugin to version 1.2.8 or later, or disable/remove it until a fix is applied.
What to do
The CVE record does not list a fixed version. Check the vendor's site or the advisory links below - a fix may already be released.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| wpdeveloper | typing_text |
<= 1.2.7 cpe:2.3:a:wpdeveloper:typing_text:*:*:*:*:*:wordpress:*:* |
Original advisory text
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WPDeveloper Typing Text typing-text allows Stored XSS.This issue affects Typing Text: from n/a ...
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WPDeveloper Typing Text typing-text allows Stored XSS.This issue affects Typing Text: from n/a through <= 1.2.7.
References
- https://patchstack.com/database/wordpress/plugin/typing-text/vulnerability/wordp... Third Party Advisory
- https://patchstack.com/database/Wordpress/Plugin/typing-text/vulnerability/wordp... Third Party Advisory
Internet-facing
60 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit
- Gives an attacker partial control
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published7 Jan 2025
Updated4 Nov 2026
First seen7 Mar 2026
Track software like this
Free during beta