Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
5.4
CVE-2025-1663: Unlimited Elements For Elementor plugin: Malicious scripts injected into WordPress pages
CVE-2025-1663 · published 1 year ago
Summary
The Unlimited Elements For Elementor plugin for WordPress is vulnerable to a security threat that allows attackers with certain levels of access to inject malicious code into pages, which can execute when users visit those pages. This can potentially compromise website security and user data. Update the plugin to a version higher than 1.5.142 to fix the issue.
What to do
The CVE record does not list a fixed version. Check the vendor's site or the advisory links below - a fix may already be released.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| unlimited-elements | unlimited_elements_for_elementor |
<= 1.5.142 cpe:2.3:a:unlimited-elements:unlimited_elements_for_elementor:*:*:*:*:*:wordpress:*:* |
Original advisory text
The Unlimited Elements For Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via several widgets in all versions up to, and including, 1.5.142 due to insufficient input sa...
The Unlimited Elements For Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via several widgets in all versions up to, and including, 1.5.142 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Internet-facing
60 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit
- Gives an attacker partial control
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published3 Apr 2025
Updated29 Oct 2026
First seen7 Mar 2026
Sources
CVE-2025-1663 · NVD
Track software like this
Free during beta