Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
5.5
CVE-2025-12632: RandomQuotr Plugin for WordPress Allows Admins to Inject Malicious Code
CVE-2025-12632 · published 11 months ago
Summary
The RandomQuotr plugin for WordPress has a security flaw that allows administrators to inject malicious code into pages, which can affect multi-site installations and installations where extra security settings are in place. This could allow an attacker to take control of a website. To fix this, update to version 1.0.5 or later, and consider enabling extra security settings to prevent similar issues in the future.
Original advisory text
The RandomQuotr plugin for WordPress is vulnerable to Stored Cross-Site Scripting via admin settings in all versions up to, and including, 1.0.4 due to insufficient input sanitization and output es...
The RandomQuotr plugin for WordPress is vulnerable to Stored Cross-Site Scripting via admin settings in all versions up to, and including, 1.0.4 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.
Internet-facing
60 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit
- Gives an attacker partial control
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published11 Nov 2025
Updated29 Oct 2026
First seen7 Mar 2026
Sources
CVE-2025-12632 · NVD
Track software like this
Free during beta