Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
8.4

CVE-2025-11344: ILIAS certificate import can let attackers run code

CVE-2025-11344 · published 1 year ago
Summary

The certificate import feature in ILIAS versions up to 8.23, 9.13, and 10.1 can be tricked into running malicious code from a remote location. This could allow an attacker to take control of the server hosting ILIAS. Update to ILIAS 8.24, 9.14, or 10.2 as soon as possible to fix the problem.

What to do

The CVE record does not list a fixed version. Check the vendor's site or the advisory links below - a fix may already be released.

Affected software
VendorProductAffected versions
ilias ilias 8.23
9.13
10.1
cpe:2.3:a:ilias:ilias:8.23:*:*:*:*:*:*:*
Original advisory text
ILIAS Certificate Import code injection
A vulnerability was detected in ILIAS up to 8.23/9.13/10.1. Affected by this vulnerability is an unknown functionality of the component Certificate Import Handler. The manipulation results in Remote Code Execution. The attack may be performed from remote. Upgrading to version 8.24, 9.14 and 10.2 addresses this issue. It is recommended to upgrade the affected component.
Fix within
Internet-facing 60 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit
  • Gives an attacker partial control
Severity
8.4 High
Exploitation
<1% chance of attack within 30 days
Type
CWE-74Injection
CWE-94Code Injection
Timeline
Published6 Oct 2025
Updated4 Nov 2026
First seen7 Mar 2026
Sources
Track software like this
Free during beta