Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
6.9

CVE-2024-9622: Resteasy Netty4 may cause client timeouts

CVE-2024-9622 · published 2 years ago
Summary

The Resteasy Netty4 libraries (resteasy-netty4-cdi, resteasy-reactor-netty, and related components) can stop processing legitimate requests after receiving a specially crafted HTTP message. This can make clients wait until they time out, which can affect systems behind load balancers. Update to the latest version of the affected libraries or apply the vendor’s recommended fix to prevent the problem.

What to do
  • Update canonical resteasy to version 3.0.6-3ubuntu0.1~esm1.
  • Update canonical resteasy3.0 to version 3.0.26-1~18.04.1~esm1.
  • Update canonical resteasy to version 3.6.2-2ubuntu0.20.04.1~esm1.
  • Update canonical resteasy3.0 to version 3.0.26-1ubuntu0.1~esm1.
  • Update canonical resteasy3.0 to version 3.0.26-3ubuntu0.1.
  • Update canonical resteasy to version 3.6.2-2ubuntu0.22.04.1~esm1.
  • Update canonical resteasy3.0 to version 3.0.26-6ubuntu0.24.04.1.
  • Update canonical resteasy to version 3.6.2-2ubuntu0.24.04.1~esm1.
  • Update jboss org.jboss.resteasy:resteasy-netty4-cdi to version 7.0.0.Alpha3 or later.
Affected software
Ecosystem VendorProductAffected versions
maven jboss org.jboss.resteasy:resteasy-netty4-cdi < 7.0.0.Alpha3
Ubuntu:Pro:16.04:LTS canonical resteasy < 3.0.6-3ubuntu0.1~esm1
Fix: upgrade to 3.0.6-3ubuntu0.1~esm1
Ubuntu:Pro:18.04:LTS canonical resteasy3.0 < 3.0.26-1~18.04.1~esm1
Fix: upgrade to 3.0.26-1~18.04.1~esm1
Ubuntu:Pro:20.04:LTS canonical resteasy < 3.6.2-2ubuntu0.20.04.1~esm1
Fix: upgrade to 3.6.2-2ubuntu0.20.04.1~esm1
Ubuntu:Pro:20.04:LTS canonical resteasy3.0 < 3.0.26-1ubuntu0.1~esm1
Fix: upgrade to 3.0.26-1ubuntu0.1~esm1
Ubuntu:22.04:LTS canonical resteasy3.0 < 3.0.26-3ubuntu0.1
Fix: upgrade to 3.0.26-3ubuntu0.1
Ubuntu:Pro:22.04:LTS canonical resteasy < 3.6.2-2ubuntu0.22.04.1~esm1
Fix: upgrade to 3.6.2-2ubuntu0.22.04.1~esm1
Ubuntu:24.04:LTS canonical resteasy3.0 < 3.0.26-6ubuntu0.24.04.1
Fix: upgrade to 3.0.26-6ubuntu0.24.04.1
Ubuntu:Pro:24.04:LTS canonical resteasy < 3.6.2-2ubuntu0.24.04.1~esm1
Fix: upgrade to 3.6.2-2ubuntu0.24.04.1~esm1
Ubuntu:25.10 canonical resteasy All versions
Ubuntu:25.10 canonical resteasy3.0 All versions
Original advisory text
Resteasy-netty4-cdi: resteasy-netty4: resteasy-reactor-netty: http request smuggling leading to client timeouts in resteasy-netty4
A vulnerability was found in the resteasy-netty4 library arising from improper handling of HTTP requests using smuggling techniques. When an HTTP smuggling request with an ASCII control character is sent, it causes the Netty HttpObjectDecoder to transition into a BAD_MESSAGE state. As a result, any subsequent legitimate requests on the same connection are ignored, leading to client timeouts, which may impact systems using load balancers and expose them to risk.
Fix within
Internet-facing 14 days
Internal 60 days
  • Not known to be exploited
  • Can be exploited automatically
  • Gives an attacker partial control
Severity
6.9 Medium
Exploitation
<1% chance of attack within 30 days
Type
CWE-444Inconsistent Interpretation of HTTP Requests ('HTTP Request/Response Smuggling')
Timeline
Published8 Oct 2024
Updated4 Nov 2026
First seen6 Mar 2026
Track software like this
Free during beta