Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
6.5

CVE-2024-9224: WordPress Hello World Plugin Allows Attackers to Read Sensitive Files

CVE-2024-9224 · published 2 years ago
Summary

The Hello World plugin for WordPress has a security issue that allows attackers with subscriber-level access to read sensitive files on the server. This can expose confidential information. To protect your site, update the plugin to a version higher than 2.1.1.

What to do
  • Update kau-boys hello_world to version 2.2.0 or later.
Affected software
VendorProductAffected versions
kau-boys hello_world < 2.2.0
cpe:2.3:a:kau-boys:hello_world:*:*:*:*:*:wordpress:*:*
Original advisory text
The Hello World plugin for WordPress is vulnerable to Arbitrary File Reading in all versions up to, and including, 2.1.1 via the hello_world_lyric() function. This makes it possible for authenticat...
The Hello World plugin for WordPress is vulnerable to Arbitrary File Reading in all versions up to, and including, 2.1.1 via the hello_world_lyric() function. This makes it possible for authenticated attackers, with subscriber-level access and above, to read the contents of arbitrary files on the server, which can contain sensitive information.
Fix within
Internet-facing 60 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit
  • Gives an attacker partial control
Severity
6.5 Medium
Exploitation
1% chance of attack within 30 days
Type
CWE-22Path Traversal
Timeline
Published1 Oct 2024
Updated31 Oct 2026
First seen7 Mar 2026
Sources
CVE-2024-9224 · NVD
Track software like this
Free during beta