Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
5.4

CVE-2024-8967: PWA — easy way to Progressive Web App plugin for WordPress allows malicious SVG uploads

CVE-2024-8967 · published 2 years ago
Summary

An attacker with author-level access can upload a malicious SVG file that executes scripts when users visit it, potentially allowing malicious activities. This affects all versions of the PWA plugin up to 1.6.3. Update to a newer version to fix this issue.

What to do
  • Update iworks pwa to version 1.6.4 or later.
Affected software
VendorProductAffected versions
iworks pwa < 1.6.4
cpe:2.3:a:iworks:pwa:*:*:*:*:*:wordpress:*:*
Original advisory text
The PWA — easy way to Progressive Web App plugin for WordPress is vulnerable to Stored Cross-Site Scripting via SVG File uploads in all versions up to, and including, 1.6.3 due to insufficient inpu...
The PWA — easy way to Progressive Web App plugin for WordPress is vulnerable to Stored Cross-Site Scripting via SVG File uploads in all versions up to, and including, 1.6.3 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Author-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses the SVG file.
Fix within
Internet-facing 14 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit
  • Gives an attacker full control
Severity
5.4 Medium
Exploitation
<1% chance of attack within 30 days
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published2 Oct 2024
Updated4 Nov 2026
First seen7 Mar 2026
Sources
CVE-2024-8967 · NVD
Track software like this
Free during beta