Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
6.1
CVE-2024-8664: WP Test Email Plugin Vulnerable to Malicious Email Attacks
CVE-2024-8664 · published 2 years ago
Summary
The WP Test Email plugin for WordPress is susceptible to malicious email attacks due to a security flaw that allows hackers to inject malicious code into emails and trick users into performing actions. This can lead to unauthorized access to sensitive information or other security breaches. To protect your website, update the plugin to the latest version.
What to do
- Update boopathirajan wp_test_email to version 1.1.8 or later.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| boopathirajan | wp_test_email |
< 1.1.8 cpe:2.3:a:boopathirajan:wp_test_email:*:*:*:*:*:wordpress:*:* |
Original advisory text
The WP Test Email plugin for WordPress is vulnerable to Reflected Cross-Site Scripting due to the use of add_query_arg without appropriate escaping on the URL in all versions up to, and including, ...
The WP Test Email plugin for WordPress is vulnerable to Reflected Cross-Site Scripting due to the use of add_query_arg without appropriate escaping on the URL in all versions up to, and including, 1.1.7. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
Internet-facing
60 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit
- Gives an attacker partial control
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published13 Sep 2024
Updated4 Nov 2026
First seen7 Mar 2026
Sources
CVE-2024-8664 · NVD
Track software like this
Free during beta