Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
6.1
CVE-2024-8656: WPFactory Helper plugin for WordPress allows malicious scripts to be injected
CVE-2024-8656 · published 2 years ago
Summary
The WPFactory Helper plugin for WordPress is open to a security risk that allows hackers to inject malicious code into websites. This could happen if a user clicks on a link sent by the attacker. To protect your site, update the plugin to the latest version.
What to do
- Update wpfactory wpfactory_helper to version 1.7.1 or later.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| wpfactory | wpfactory_helper |
< 1.7.1 cpe:2.3:a:wpfactory:wpfactory_helper:*:*:*:*:*:wordpress:*:* |
Original advisory text
The WPFactory Helper plugin for WordPress is vulnerable to Reflected Cross-Site Scripting due to the use of add_query_arg without appropriate escaping on the URL in all versions up to, and includin...
The WPFactory Helper plugin for WordPress is vulnerable to Reflected Cross-Site Scripting due to the use of add_query_arg without appropriate escaping on the URL in all versions up to, and including, 1.7.0. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
References
Internet-facing
60 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit
- Gives an attacker partial control
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published13 Sep 2024
Updated4 Nov 2026
First seen7 Mar 2026
Sources
CVE-2024-8656 · NVD
Track software like this
Free during beta